程序集缓存查看器

.NET Framework 开发人员指南
程序集缓存查看器
DropDown image

程序集缓存查看器是一种 Windows 外壳扩展，它使您得以使用 Windows 资源管理器查看和操作全局程序集缓存的内容。

使用程序集缓存查看器

使用程序集缓存查看器可以执行以下操作：

  • 查看程序集缓存的内容。

  • 查看和更改下载的缓存大小限制。

  • 查看单个程序集属性。

  • 将程序集添加到缓存中。

  • 从缓存中删除程序集。

  • 显示帮助信息。

查看程序集缓存的内容

  • 在 Windows 资源管理器中，定位到 Windows 目录 <系统驱动器>:\<Windows 文件夹>\assembly 的 \assembly 子目录。全局程序集缓存的内容随即显示出来。

    Shfusion.dll 使程序集文件夹的内容以不同于标准 Windows 文件夹内容的形式出现。随即显示全局程序集缓存中安装的程序集的名称，以及有关每个程序集的类型、版本、区域性和公钥标记的详细信息。

    Shfusion.dll 位于 %windir%\Microsoft.NET\Framework\vx.x.xxxx 文件夹中，其中 vx.x.xxxx 是最高的 .NET Framework 安装版本。例如，如果安装了版本 v1.1.4322 和 v1.0.5000，则使用 v1.1.4322。

下面的屏幕抓图显示了在查看器中显示的程序集缓存的内容。

全局程序集缓存的内容

查看和更改下载的缓存大小限制

  • 从 Windows NT 系统中的“工具”菜单或 Windows 98 系统中的“视图”菜单中选择“配置缓存设置”。或者，可以使用工具栏上的“配置缓存设置”图标。

    出现“缓存属性”对话框。该对话框类似于传统的驱动器属性对话框，只不过前者以 MB 为单位显示已使用的缓存空间量。

下面的屏幕抓图显示了“缓存属性”对话框。

“缓存属性”对话框

查看程序集属性

  • 在查看器中右击程序集名称，并从快捷菜单中选择“属性”。

    出现一个“属性”窗口，显示该程序集的名称、版本、区域性、公钥、作为该程序集来源的基本代码和该程序集的最后修改日期。也可以从“文件”菜单查看程序集的属性。

下面的屏幕抓图显示了 System.Data 程序集的“属性”窗口。

“程序集属性”窗口

将程序集添加到缓存中

  • 使用 Windows 资源管理器将包含清单的文件拖放到程序集缓存目录中。只有具有强名称的程序集才可以添加到缓存中。

如果有 .NET Framework SDK，您也可以使用全局程序集缓存工具 (Gacutil.exe) 将程序集添加到缓存中。

从缓存中删除程序集

  • 在查看器中右击程序集，并从快捷菜单中选择“删除”。

也可以从“文件”菜单中删除程序集，如果有 .NET Framework SDK，则还可以使用 “Gacutil.exe” 删除程序集。

显示查看器的帮助

  • 使用 F1 键，或从“帮助”菜单中选择“帮助主题”。

要提出有关“帮助”或本产品其他功能的建议或错误报告，请转到反馈站点。


shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
DropDown image

shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

要提出有关“帮助”或本产品其他功能的建议或错误报告，请转到反馈站点。